CVE-2017-12163

NameCVE-2017-12163
DescriptionAn information leak flaw was found in the way SMB1 protocol was implemented by Samba before 4.4.16, 4.5.x before 4.5.14, and 4.6.x before 4.6.8. A malicious client could use this flaw to dump server memory contents to a file on the samba share or to a shared printer, though the exact area of server memory cannot be controlled by the attacker.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1110-1, DSA-3983-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)stretch (security), stretch2:4.5.16+dfsg-1+deb9u2fixed
buster2:4.9.5+dfsg-5fixed
buster (security)2:4.9.5+dfsg-5+deb10u1fixed
bullseye, sid2:4.12.5+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasourcewheezy2:3.6.6-6+deb7u14DLA-1110-1
sambasourcejessie2:4.2.14+dfsg-0+deb8u8DSA-3983-1
sambasourcestretch2:4.5.8+dfsg-2+deb9u2DSA-3983-1
sambasource(unstable)2:4.6.7+dfsg-2

Notes

https://www.samba.org/samba/security/CVE-2017-12163.html

Search for package or bug name: Reporting problems