CVE-2017-12425

NameCVE-2017-12425
DescriptionAn issue was discovered in Varnish HTTP Cache 4.0.1 through 4.0.4, 4.1.0 through 4.1.7, 5.0.0, and 5.1.0 through 5.1.2. A wrong if statement in the varnishd source code means that particular invalid requests from the client can trigger an assert, related to an Integer Overflow. This causes the varnishd worker process to abort and restart, losing the cached contents in the process. An attacker can therefore crash the varnishd worker process on demand and effectively keep it from serving content - a Denial-of-Service attack. The specific source-code filename containing the incorrect statement varies across releases.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3924-1
NVD severitymedium (attack range: remote)
Debian Bugs870467

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
varnish (PTS)wheezy, wheezy (security)3.0.2-2+deb7u2fixed
jessie4.0.2-1vulnerable
jessie (security)4.0.2-1+deb8u1fixed
stretch5.0.0-7+deb9u1fixed
stretch (security)5.0.0-7+deb9u2fixed
buster5.0.0-7.1fixed
sid5.2.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
varnishsource(unstable)5.0.0-7.1medium870467
varnishsourcejessie4.0.2-1+deb8u1mediumDSA-3924-1
varnishsourcestretch5.0.0-7+deb9u1mediumDSA-3924-1
varnishsourcewheezy(not affected)

Notes

[wheezy] - varnish <not-affected> (code path is not exposed to clients)
https://www.varnish-cache.org/security/VSV00001.html#vsv00001
https://github.com/varnishcache/varnish-cache/issues/2379
https://github.com/varnishcache/varnish-cache/commit/09731b24b2225e3c0d66d3ec1b4fedef6fa22b6e

Search for package or bug name: Reporting problems