CVE-2017-12562

NameCVE-2017-12562
DescriptionHeap-based Buffer Overflow in the psf_binheader_writef function in common.c in libsndfile through 1.0.28 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1049-1
NVD severityhigh (attack range: remote)
Debian Bugs869166

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsndfile (PTS)wheezy1.0.25-5vulnerable
wheezy (security)1.0.25-9.1+deb7u4fixed
jessie1.0.25-9.1+deb8u1vulnerable
stretch1.0.27-3vulnerable
buster, sid1.0.28-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsndfilesource(unstable)1.0.28-3high869166
libsndfilesourcewheezy1.0.25-9.1+deb7u4highDLA-1049-1

Notes

[stretch] - libsndfile <no-dsa> (Minor issue)
[jessie] - libsndfile <no-dsa> (Minor issue)
https://github.com/erikd/libsndfile/issues/292
https://github.com/erikd/libsndfile/commit/cf7a8182c2642c50f1cf90dddea9ce96a8bad2e8

Search for package or bug name: Reporting problems