CVE-2017-12583

NameCVE-2017-12583
DescriptionDokuWiki through 2017-02-19b has XSS in the at parameter (aka the DATE_AT variable) to doku.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs870903

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dokuwiki (PTS)bullseye0.0.20180422.a-2.1fixed
bookworm, sid, trixie0.0.20220731.a-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dokuwikisourcewheezy(not affected)
dokuwikisourcejessie(not affected)
dokuwikisource(unstable)0.0.20180422.a-1870903

Notes

[jessie] - dokuwiki <not-affected> (Vulnerable code not present)
[wheezy] - dokuwiki <not-affected> (Vulnerable code not present)
https://github.com/splitbrain/dokuwiki/issues/2061

Search for package or bug name: Reporting problems