CVE-2017-12618

NameCVE-2017-12618
DescriptionApache Portable Runtime Utility (APR-util) 1.6.0 and prior fail to validate the integrity of SDBM database files used by apr_sdbm*() functions, resulting in a possible out of bound read access. A local user with write access to the database can make a program or process using these functions crash, and cause a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1163-1
NVD severitylow (attack range: local)
Debian Bugs879996

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apr-util (PTS)jessie1.5.4-1vulnerable
stretch1.5.4-3vulnerable
buster, sid1.6.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apr-utilsource(unstable)1.6.1-1low879996
apr-utilsourcewheezy1.4.1-3+deb7u1lowDLA-1163-1

Notes

[stretch] - apr-util <no-dsa> (Minor issue)
[jessie] - apr-util <no-dsa> (Minor issue)
mail-archives.apache.org/mod_mbox/apr-dev/201710.mbox/%3CCACsi252POs4toeJJciwg09_eu2cO3XFg%3DUqsPjXsfjDoeC3-UQ%40mail.gmail.com%3E
https://github.com/apache/apr/commit/f672b565c825c34de9ee298b5bdc62c01cdd6147

Search for package or bug name: Reporting problems