CVE-2017-12652

NameCVE-2017-12652
Descriptionlibpng before 1.6.32 does not properly check the length of chunks against the user limit.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpng1.6 (PTS)stretch (security), stretch1.6.28-1+deb9u1vulnerable
buster1.6.36-6fixed
bullseye, sid1.6.37-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpng1.6source(unstable)1.6.32-1

Notes

[stretch] - libpng1.6 <ignored> (Minor issue)
https://github.com/glennrp/libpng/commit/347538efbdc21b8df684ebd92d37400b3ce85d55
https://github.com/glennrp/libpng/commit/a1fe2c98489519d415b72bc0026f0c86d82278b7
https://github.com/glennrp/libpng/commit/095b4ce16bb46acb259ea1a4ca6562a623e58d93
https://github.com/glennrp/libpng/commit/2dbef2f2a9e759a80d2decb6862518acf4919c59
https://github.com/glennrp/libpng/commit/2dca15686fadb1b8951cb29b02bad4cae73448da
https://github.com/glennrp/libpng/commit/fcd1bb93124d76059abef98216d8390f520c577b
https://github.com/glennrp/libpng/commit/13bc0b6b1f8f2f2491fcc9f0c1c939ff06e13c15

Search for package or bug name: Reporting problems