CVE-2017-12663

NameCVE-2017-12663
DescriptionImageMagick 7.0.6-2 has a memory leak vulnerability in WriteMAPImage in coders/map.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs870483

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)jessie8:6.8.9.9-5+deb8u11vulnerable
jessie (security)8:6.8.9.9-5+deb8u12vulnerable
stretch8:6.9.7.4+dfsg-11+deb9u3vulnerable
stretch (security)8:6.9.7.4+dfsg-11+deb9u4vulnerable
buster8:6.9.9.34+dfsg-3fixed
sid8:6.9.9.39+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)8:6.9.7.4+dfsg-16unimportant870483

Notes

https://github.com/ImageMagick/ImageMagick/issues/573

Search for package or bug name: Reporting problems