CVE-2017-12669

NameCVE-2017-12669
DescriptionImageMagick 7.0.6-2 has a memory leak vulnerability in WriteCALSImage in coders/cals.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs870475

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)jessie8:6.8.9.9-5+deb8u12vulnerable
jessie (security)8:6.8.9.9-5+deb8u13vulnerable
stretch8:6.9.7.4+dfsg-11+deb9u3vulnerable
stretch (security)8:6.9.7.4+dfsg-11+deb9u5vulnerable
buster, sid8:6.9.10.8+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)8:6.9.7.4+dfsg-16unimportant870475

Notes

https://github.com/ImageMagick/ImageMagick/issues/571

Search for package or bug name: Reporting problems