CVE-2017-12867

NameCVE-2017-12867
DescriptionThe SimpleSAML_Auth_TimeLimitedToken class in SimpleSAMLphp 1.14.14 and earlier allows attackers with access to a secret token to extend its validity period by manipulating the prepended time offset.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1205-1, DSA-4127-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
simplesamlphp (PTS)stretch (security), stretch1.14.11-1+deb9u2fixed
buster1.16.3-1+deb10u2fixed
buster (security)1.16.3-1+deb10u1fixed
bullseye, sid1.18.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
simplesamlphpsourcewheezy1.9.2-1+deb7u1DLA-1205-1
simplesamlphpsourcejessie1.13.1-2+deb8u1DSA-4127-1
simplesamlphpsourcestretch1.14.11-1+deb9u1DSA-4127-1
simplesamlphpsource(unstable)1.14.15-1

Notes

https://simplesamlphp.org/security/201708-01
Patch: https://github.com/simplesamlphp/simplesamlphp/commit/608f24c2d5afd70c2af050785d2b12f878b33c68

Search for package or bug name: Reporting problems