CVE-2017-12868

NameCVE-2017-12868
DescriptionThe secureCompare method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.13 and earlier, when used with PHP before 5.6, allows attackers to conduct session fixation attacks or possibly bypass authentication by leveraging missing character conversions before an XOR operation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1205-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
simplesamlphp (PTS)wheezy1.9.2-1vulnerable
wheezy (security)1.9.2-1+deb7u4fixed
jessie1.13.1-2vulnerable
jessie (security)1.13.1-2+deb8u1vulnerable
stretch (security), stretch1.14.11-1+deb9u1vulnerable
buster, sid1.15.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
simplesamlphpsource(unstable)1.14.15-1high
simplesamlphpsourcewheezy1.9.2-1+deb7u1highDLA-1205-1

Notes

https://simplesamlphp.org/security/201705-01
Patch: https://github.com/simplesamlphp/simplesamlphp/commit/caf764cc2c9b68ac29741070ebdf133a595443f1

Search for package or bug name: Reporting problems