CVE-2017-12869

NameCVE-2017-12869
DescriptionThe multiauth module in SimpleSAMLphp 1.14.13 and earlier allows remote attackers to bypass authentication context restrictions and use an authentication source defined in config/authsources.php via vectors related to improper validation of user input.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1205-1, DSA-4127-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
simplesamlphp (PTS)wheezy1.9.2-1vulnerable
wheezy (security)1.9.2-1+deb7u4fixed
jessie1.13.1-2vulnerable
jessie (security)1.13.1-2+deb8u1fixed
stretch (security), stretch1.14.11-1+deb9u1fixed
buster, sid1.15.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
simplesamlphpsource(unstable)1.14.15-1medium
simplesamlphpsourcejessie1.13.1-2+deb8u1mediumDSA-4127-1
simplesamlphpsourcestretch1.14.11-1+deb9u1mediumDSA-4127-1
simplesamlphpsourcewheezy1.9.2-1+deb7u1mediumDLA-1205-1

Notes

https://simplesamlphp.org/security/201704-02
Patch: https://github.com/simplesamlphp/simplesamlphp/commit/f1e485284dd428ab3cd9500c62e19c7c7234be9a

Search for package or bug name: Reporting problems