DescriptionSimpleSAMLphp 1.14.12 and earlier make it easier for man-in-the-middle attackers to obtain sensitive information by leveraging use of the aesEncrypt and aesDecrypt methods in the SimpleSAML/Utils/Crypto class to protect session identifiers in replies to non-HTTPS service providers.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
simplesamlphp (PTS)wheezy1.9.2-1vulnerable
wheezy (security)1.9.2-1+deb7u4vulnerable
jessie (security)1.13.1-2+deb8u1vulnerable
stretch (security), stretch1.14.11-1+deb9u1vulnerable
buster, sid1.15.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[wheezy] - simplesamlphp <ignored> (Minor issue mitigated by HTTPS usage, hard to backport)

Search for package or bug name: Reporting problems