CVE-2017-12871

NameCVE-2017-12871
DescriptionThe aesEncrypt method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.x through 1.14.11 makes it easier for context-dependent attackers to bypass the encryption protection mechanism by leveraging use of the first 16 bytes of the secret key as the initialization vector (IV).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
simplesamlphp (PTS)jessie1.13.1-2+deb8u1fixed
jessie (security)1.13.1-2+deb8u2fixed
stretch (security), stretch1.14.11-1+deb9u1vulnerable
buster, sid1.16.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
simplesamlphpsource(unstable)1.14.15-1medium
simplesamlphpsourcejessie(not affected)
simplesamlphpsourcewheezy(not affected)

Notes

[jessie] - simplesamlphp <not-affected> (Vulnerable code not present)
[wheezy] - simplesamlphp <not-affected> (Vulnerable code not present)
https://simplesamlphp.org/security/201703-02

Search for package or bug name: Reporting problems