CVE-2017-12877

NameCVE-2017-12877
DescriptionUse-after-free vulnerability in the DestroyImage function in image.c in ImageMagick before 7.0.6-6 allows remote attackers to cause a denial of service via a crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1081-1, DSA-4040-1, DSA-4074-1
NVD severitymedium (attack range: remote)
Debian Bugs872373

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)jessie8:6.8.9.9-5+deb8u12fixed
jessie (security)8:6.8.9.9-5+deb8u15fixed
stretch (security), stretch8:6.9.7.4+dfsg-11+deb9u6fixed
buster, sid8:6.9.10.14+dfsg-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)8:6.9.9.34+dfsg-3medium872373
imagemagicksourcejessie8:6.8.9.9-5+deb8u11mediumDSA-4040-1
imagemagicksourcestretch8:6.9.7.4+dfsg-11+deb9u4mediumDSA-4074-1
imagemagicksourcewheezy8:6.7.7.10-5+deb7u16mediumDLA-1081-1

Notes

https://github.com/ImageMagick/ImageMagick/issues/662
ImageMagick-6: https://github.com/ImageMagick/ImageMagick/commit/98dda239ec398dd56453460849b4c9057fc424e5
ImageMagick-7: https://github.com/ImageMagick/ImageMagick/commit/04178de2247e353fc095846784b9a10fefdbf890
This doesn't affect the base releases, but got introduced via security fixes, which got backported to older suites

Search for package or bug name: Reporting problems