CVE-2017-12979

NameCVE-2017-12979
DescriptionDokuWiki through 2017-02-19c has stored XSS when rendering a malicious language name in a code element, in /inc/parser/xhtml.php. An attacker can create or edit a wiki with this element to trigger JavaScript execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs872940

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dokuwiki (PTS)jessie0.0.20140505.a+dfsg-4vulnerable
jessie (security)0.0.20140505.a+dfsg-4+deb8u1vulnerable
bullseye, sid, buster0.0.20180422.a-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dokuwikisource(unstable)0.0.20180422.a-1872940

Notes

[jessie] - dokuwiki <no-dsa> (Minor issue)
[wheezy] - dokuwiki <no-dsa> (Minor issue)
https://github.com/splitbrain/dokuwiki/issues/2080
https://github.com/splitbrain/dokuwiki/commit/56bd9509ab2037512829392fda6427af7f390724

Search for package or bug name: Reporting problems