CVE-2017-13022

NameCVE-2017-13022
DescriptionThe IP parser in tcpdump before 4.9.2 has a buffer over-read in print-ip.c:ip_printroute().
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1097-1, DSA-3971-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tcpdump (PTS)wheezy4.3.0-1+deb7u2vulnerable
wheezy (security)4.9.2-1~deb7u1fixed
jessie4.9.0-1~deb8u1vulnerable
jessie (security)4.9.2-1~deb8u1fixed
stretch4.9.0-2vulnerable
stretch (security)4.9.2-1~deb9u1fixed
buster, sid4.9.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tcpdumpsource(unstable)4.9.2-1high
tcpdumpsourcejessie4.9.2-1~deb8u1highDSA-3971-1
tcpdumpsourcestretch4.9.2-1~deb9u1highDSA-3971-1
tcpdumpsourcewheezy4.9.2-1~deb7u1highDLA-1097-1

Search for package or bug name: Reporting problems