CVE-2017-13141

NameCVE-2017-13141
DescriptionIn ImageMagick before 6.9.9-4 and 7.x before 7.0.6-4, a crafted file could trigger a memory leak in ReadOnePNGImage in coders/png.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4019-1
NVD severitymedium (attack range: remote)
Debian Bugs870116

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)wheezy8:6.7.7.10-5+deb7u4vulnerable
wheezy (security)8:6.7.7.10-5+deb7u20vulnerable
jessie (security), jessie8:6.8.9.9-5+deb8u11vulnerable
stretch8:6.9.7.4+dfsg-11+deb9u3fixed
stretch (security)8:6.9.7.4+dfsg-11+deb9u4fixed
buster, sid8:6.9.7.4+dfsg-16fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)8:6.9.7.4+dfsg-15unimportant870116
imagemagicksourcestretch8:6.9.7.4+dfsg-11+deb9u2mediumDSA-4019-1

Notes

https://github.com/ImageMagick/ImageMagick/issues/600

Search for package or bug name: Reporting problems