CVE-2017-13144

NameCVE-2017-13144
DescriptionIn ImageMagick before 6.9.7-10, there is a crash (rather than a "width or height exceeds limit" error report) if the image dimensions are too large, as demonstrated by use of the mpc coder.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1081-1, DSA-4019-1, DSA-4040-1
NVD severitymedium
Debian Bugs869728

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)stretch8:6.9.7.4+dfsg-11+deb9u8fixed
stretch (security)8:6.9.7.4+dfsg-11+deb9u13fixed
buster, buster (security)8:6.9.10.23+dfsg-2.1+deb10u1fixed
bookworm, sid, bullseye8:6.9.11.60+dfsg-1.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksourcewheezy8:6.7.7.10-5+deb7u16DLA-1081-1
imagemagicksourcejessie8:6.8.9.9-5+deb8u11DSA-4040-1
imagemagicksourcestretch8:6.9.7.4+dfsg-11+deb9u2DSA-4019-1
imagemagicksource(unstable)8:6.9.7.4+dfsg-13869728

Notes

https://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=31438
https://github.com/ImageMagick/ImageMagick/commit/9b580ad0564aefd9beeccbcbb8d62ccd05795a84

Search for package or bug name: Reporting problems