CVE-2017-13727

NameCVE-2017-13727
DescriptionThere is a reachable assertion abort in the function TIFFWriteDirectoryTagSubifd() in LibTIFF 4.0.8, related to tif_dirwrite.c and a SubIFD tag. A crafted input will lead to a remote denial of service attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1093-1, DSA-4100-1
NVD severitymedium (attack range: remote)
Debian Bugs873879

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tiff (PTS)jessie4.0.3-12.3+deb8u5fixed
jessie (security)4.0.3-12.3+deb8u8fixed
stretch (security), stretch4.0.8-2+deb9u4fixed
buster, sid4.0.10-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tiffsource(unstable)4.0.8-5medium873879
tiffsourcejessie4.0.3-12.3+deb8u5mediumDSA-4100-1
tiffsourcestretch4.0.8-2+deb9u2mediumDSA-4100-1
tiffsourcewheezy4.0.2-6+deb7u16mediumDLA-1093-1
tiff3source(unstable)(unfixed)medium
tiff3sourcewheezy(not affected)

Notes

[wheezy] - tiff3 <not-affected> (Vulnerable code not present)
http://bugzilla.maptools.org/show_bug.cgi?id=2728
Fixed by: https://github.com/vadz/libtiff/commit/b6af137bf9ef852f1a48a50a5afb88f9e9da01cc

Search for package or bug name: Reporting problems