CVE-2017-14033

NameCVE-2017-14033
DescriptionThe decode method in the OpenSSL::ASN1 module in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows attackers to cause a denial of service (interpreter crash) via a crafted string.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1114-1, DSA-4031-1
NVD severitymedium (attack range: remote)
Debian Bugs875928

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby1.8 (PTS)wheezy1.8.7.358-7.1+deb7u3fixed
wheezy (security)1.8.7.358-7.1+deb7u4fixed
ruby1.9.1 (PTS)wheezy1.9.3.194-8.1+deb7u5vulnerable
wheezy (security)1.9.3.194-8.1+deb7u6fixed
ruby2.1 (PTS)jessie2.1.5-2+deb8u3vulnerable
jessie (security)2.1.5-2+deb8u1vulnerable
ruby2.3 (PTS)buster, stretch2.3.3-1+deb9u1vulnerable
stretch (security)2.3.3-1+deb9u2fixed
sid2.3.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby1.8source(unstable)(not affected)
ruby1.9.1source(unstable)(unfixed)medium
ruby1.9.1sourcewheezy1.9.3.194-8.1+deb7u6mediumDLA-1114-1
ruby2.1source(unstable)(unfixed)medium
ruby2.3source(unstable)2.3.5-1medium875928
ruby2.3sourcestretch2.3.3-1+deb9u2mediumDSA-4031-1

Notes

- ruby1.8 <not-affected> (vunlerable code not present)
https://bugzilla.novell.com/show_bug.cgi?id=1058757
https://www.ruby-lang.org/en/news/2017/09/14/openssl-asn1-buffer-underrun-cve-2017-14033/
https://github.com/ruby/openssl/commit/1648afef33c1d97fb203c82291b8a61269e85d3b

Search for package or bug name: Reporting problems