CVE-2017-14041

NameCVE-2017-14041
DescriptionA stack-based buffer overflow was discovered in the pgxtoimage function in bin/jp2/convert.c in OpenJPEG 2.2.0. The vulnerability causes an out-of-bounds write, which may lead to remote denial of service or possibly remote code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4013-1
NVD severitymedium (attack range: remote)
Debian Bugs874115

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openjpeg2 (PTS)jessie2.1.0-2+deb8u2vulnerable
jessie (security)2.1.0-2+deb8u3fixed
stretch2.1.2-1.1vulnerable
stretch (security)2.1.2-1.1+deb9u2fixed
buster, sid2.3.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openjpeg2source(unstable)2.3.0-1medium874115
openjpeg2sourcejessie2.1.0-2+deb8u3mediumDSA-4013-1
openjpeg2sourcestretch2.1.2-1.1+deb9u2mediumDSA-4013-1

Notes

Fixed by: https://github.com/uclouvain/openjpeg/commit/e5285319229a5d77bf316bb0d3a6cbd3cb8666d9
Reproducer: https://blogs.gentoo.org/ago/2017/08/28/openjpeg-stack-based-buffer-overflow-write-in-pgxtoimage-convert-c/
https://github.com/uclouvain/openjpeg/issues/997

Search for package or bug name: Reporting problems