CVE-2017-14051

NameCVE-2017-14051
DescriptionAn integer overflow in the qla2x00_sysfs_write_optrom_ctl function in drivers/scsi/qla2xxx/qla_attr.c in the Linux kernel through 4.12.10 allows local users to cause a denial of service (memory corruption and system crash) by leveraging root access.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)wheezy3.2.78-1vulnerable
wheezy (security)3.2.93-1vulnerable
jessie3.16.43-2+deb8u2vulnerable
jessie (security)3.16.43-2+deb8u5fixed
stretch4.9.51-1fixed
stretch (security)4.9.30-2+deb9u5fixed
buster4.13.4-2fixed
sid4.13.13-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.12.13-1unimportant
linuxsourcejessie3.16.43-2+deb8u5medium
linuxsourcestretch4.9.30-2+deb9u5medium

Notes

Fixed by: https://git.kernel.org/linus/e6f77540c067b48dee10f1e33678415bfcc89017
https://patchwork.kernel.org/patch/9929625/
Non issue, only "exploitable" with root access

Search for package or bug name: Reporting problems