CVE-2017-14061

NameCVE-2017-14061
DescriptionInteger overflow in the _isBidi function in bidi.c in Libidn2 before 2.0.4 allows remote attackers to cause a denial of service or possibly have unspecified other impact.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs873904

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libidn (PTS)stretch1.33-1+deb9u1fixed
buster1.33-2.2fixed
bullseye1.33-3fixed
bookworm1.38-3fixed
sid1.38-4fixed
libidn2-0 (PTS)stretch (security), stretch0.16-1+deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libidnsource(unstable)(not affected)
libidn2-0sourcewheezy(not affected)
libidn2-0sourcejessie(not affected)
libidn2-0sourcestretch(not affected)
libidn2-0source(unstable)2.0.2-4873904

Notes

[stretch] - libidn2-0 <not-affected> (Vulnerable code not present)
[jessie] - libidn2-0 <not-affected> (Vulnerable code not present)
[wheezy] - libidn2-0 <not-affected> (Vulnerable code not present)
- libidn <not-affected> (Vulnerable code not present)
https://gitlab.com/libidn/libidn2/commit/16853b6973a1e72fee2b7cccda85472cb9951305

Search for package or bug name: Reporting problems