DescriptionInteger overflow in the _isBidi function in bidi.c in Libidn2 before 2.0.4 allows remote attackers to cause a denial of service or possibly have unspecified other impact.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs873904

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libidn (PTS)wheezy1.25-2fixed
wheezy (security)1.25-2+deb7u3fixed
jessie (security), jessie1.29-1+deb8u2fixed
buster, sid1.33-2fixed
libidn2-0 (PTS)wheezy0.8-2fixed
wheezy (security)0.8-2+deb7u1fixed
jessie (security)0.10-2+deb8u1fixed
stretch (security), stretch0.16-1+deb9u1fixed
buster, sid2.0.2-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libidnsource(unstable)(not affected)
libidn2-0sourcejessie(not affected)
libidn2-0sourcestretch(not affected)
libidn2-0sourcewheezy(not affected)


[stretch] - libidn2-0 <not-affected> (Vulnerable code not present)
[jessie] - libidn2-0 <not-affected> (Vulnerable code not present)
[wheezy] - libidn2-0 <not-affected> (Vulnerable code not present)
- libidn <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems