CVE-2017-14098

NameCVE-2017-14098
DescriptionIn the pjsip channel driver (res_pjsip) in Asterisk 13.x before 13.17.1 and 14.x before 14.6.1, a carefully crafted tel URI in a From, To, or Contact header could cause Asterisk to crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs873909

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
asterisk (PTS)buster1:16.2.1~dfsg-1+deb10u2fixed
buster (security)1:16.28.0~dfsg-0+deb10u1fixed
bullseye1:16.16.1~dfsg-1+deb11u1fixed
bullseye (security)1:16.28.0~dfsg-0+deb11u1fixed
bookworm, sid1:20.0.0~dfsg+~cs6.12.40431414-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
asterisksourcewheezy(not affected)
asterisksourcejessie(not affected)
asterisksourcestretch(not affected)
asterisksource(unstable)1:13.17.1~dfsg-1873909

Notes

[stretch] - asterisk <not-affected> (Vulnerable code not present; issue introduced in 13.15)
[jessie] - asterisk <not-affected> (Vulnerable code not present; issue introduced in 13.15)
[wheezy] - asterisk <not-affected> (Vulnerable code not present; issue introduced in 13.15)
https://issues.asterisk.org/jira/browse/ASTERISK-27152
Fix: https://gerrit.asterisk.org/#/q/topic:ASTERISK-27152

Search for package or bug name: Reporting problems