CVE-2017-14102

NameCVE-2017-14102
DescriptionMIMEDefang 2.80 and earlier creates a PID file after dropping privileges to a non-root account, which might allow local users to kill arbitrary processes by leveraging access to this non-root account for PID file modification before a root script executes a "kill `cat /pathname`" command, as demonstrated by the init-script.in and mimedefang-init.in scripts.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: local)
Debian Bugs877363

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mimedefang (PTS)wheezy2.71-3vulnerable
jessie2.75-1vulnerable
buster, sid, stretch2.79-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mimedefangsource(unstable)(unfixed)medium877363

Notes

[stretch] - mimedefang <no-dsa> (Minor issue)
[jessie] - mimedefang <no-dsa> (Minor issue)
[wheezy] - mimedefang <ignored> (Minor issue only exploitable if daemon is compromised in some other way)
http://lists.roaringpenguin.com/pipermail/mimedefang/2017-August/038077.html
http://lists.roaringpenguin.com/pipermail/mimedefang/2017-August/038085.html

Search for package or bug name: Reporting problems