CVE-2017-14107

NameCVE-2017-14107
DescriptionThe _zip_read_eocd64 function in zip_open.c in libzip before 1.3.0 mishandles EOCD records, which allows remote attackers to cause a denial of service (memory allocation failure in _zip_cdir_grow in zip_dirent.c) via a crafted ZIP archive.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs874010

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libzip (PTS)wheezy0.10.1-1.1vulnerable
jessie0.11.2-1.2vulnerable
buster, sid, stretch1.1.2-1.1vulnerable
php5 (PTS)wheezy5.4.45-0+deb7u2vulnerable
wheezy (security)5.4.45-0+deb7u11vulnerable
jessie (security), jessie5.6.30+dfsg-0+deb8u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libzipsource(unstable)(unfixed)low874010
libzipsourceexperimental1.3.0+dfsg.1-1medium
php5source(unstable)(unfixed)unimportant

Notes

[stretch] - libzip <no-dsa> (Minor issue)
[jessie] - libzip <no-dsa> (Minor issue)
[wheezy] - libzip <no-dsa> (Minor issue)
https://blogs.gentoo.org/ago/2017/09/01/libzip-memory-allocation-failure-in-_zip_cdir_grow-zip_dirent-c/
https://github.com/nih-at/libzip/commit/9b46957ec98d85a572e9ef98301247f39338a3b5
PHP commit: https://github.com/php/php-src/commit/f6e8ce812174343b5c9fd1860f9e2e2864428567
Marked as unimportant, php5 uses system libzip since 5.4.5-1

Search for package or bug name: Reporting problems