CVE-2017-14316

NameCVE-2017-14316
DescriptionA parameter verification issue was discovered in Xen through 4.9.x. The function `alloc_heap_pages` allows callers to specify the first NUMA node that should be used for allocations through the `memflags` parameter; the node is extracted using the `MEMF_get_node` macro. While the function checks to see if the special constant `NUMA_NO_NODE` is specified, it otherwise does not handle the case where `node >= MAX_NUMNODES`. This allows an out-of-bounds access to an internal array.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1132-1, DSA-4050-1
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)wheezy4.1.4-3+deb7u9vulnerable
wheezy (security)4.1.6.lts1-11fixed
jessie (security), jessie4.4.1-9+deb8u10vulnerable
buster, sid, stretch (security), stretch4.8.2+xsa245-0+deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.8.2+xsa245-0+deb9u1high
xensourcestretch4.8.2+xsa245-0+deb9u1highDSA-4050-1
xensourcewheezy4.1.6.lts1-9highDLA-1132-1

Notes

https://xenbits.xen.org/xsa/advisory-231.html

Search for package or bug name: Reporting problems