CVE-2017-14617

NameCVE-2017-14617
DescriptionIn Poppler 0.59.0, a floating point exception occurs in the ImageStream class in Stream.cc, which may lead to a potential attack when handling malicious PDF files.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1116-1
NVD severitymedium (attack range: remote)
Debian Bugs876385

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)jessie0.26.5-2+deb8u4vulnerable
jessie (security)0.26.5-2+deb8u7vulnerable
stretch (security), stretch0.48.0-2+deb9u2vulnerable
buster, sid0.71.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
popplersource(unstable)0.61.1-2medium876385
popplersourcewheezy0.18.4-6+deb7u3mediumDLA-1116-1

Notes

[stretch] - poppler <ignored> (Minor issue)
[jessie] - poppler <ignored> (Minor issue)
https://bugs.freedesktop.org/show_bug.cgi?id=102854
https://cgit.freedesktop.org/poppler/poppler/commit/?id=939465c40902d72e0c05d4f3a27ee67e4a007ed7
The patch applied in 0.48.0-2+deb9u1 (stretch) and 0.26.5-2+deb8u2 (jessie)
does not completely fix the issue thus still marked as unfixed even if the
CVE is recorded in debian/changelog.

Search for package or bug name: Reporting problems