CVE-2017-14687

NameCVE-2017-14687
DescriptionArtifex MuPDF 1.11 allows attackers to cause a denial of service or possibly have unspecified other impact via a crafted .xps file, related to "Data from Faulting Address controls Branch Selection starting at mupdf+0x000000000016cb4f" on Windows. This occurs because of mishandling of XML tag name comparisons.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1164-1, DSA-4006-1
Debian Bugs877379

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mupdf (PTS)buster1.14.0+ds1-4+deb10u3fixed
buster (security)1.14.0+ds1-4+deb10u2fixed
bullseye1.17.0+ds1-2fixed
bullseye (security)1.17.0+ds1-1.3~deb11u1fixed
bookworm1.21.1+ds1-2fixed
sid1.21.1+ds2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mupdfsourcewheezy0.9-2+deb7u4DLA-1164-1
mupdfsourcestretch1.9a+ds1-4+deb9u1DSA-4006-1
mupdfsource(unstable)1.11+ds1-1.1877379

Notes

[jessie] - mupdf <no-dsa> (Minor issue)
https://bugs.ghostscript.com/show_bug.cgi?id=698558
Fixed by: https://git.ghostscript.com/?p=mupdf.git;h=2b16dbd8f73269cb15ca61ece75cf8d2d196ed28
Several fz_xml_tag && !strcmp idoms are used in older versions

Search for package or bug name: Reporting problems