CVE-2017-14746

NameCVE-2017-14746
DescriptionUse-after-free vulnerability in Samba 4.x before 4.7.3 allows remote attackers to execute arbitrary code via a crafted SMB1 request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4043-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)jessie2:4.2.14+dfsg-0+deb8u9fixed
jessie (security)2:4.2.14+dfsg-0+deb8u13fixed
stretch2:4.5.16+dfsg-1+deb9u1fixed
stretch (security)2:4.5.16+dfsg-1+deb9u2fixed
buster2:4.9.5+dfsg-5fixed
bullseye, sid2:4.9.11+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasource(unstable)2:4.7.1+dfsg-2high
sambasourcejessie2:4.2.14+dfsg-0+deb8u9highDSA-4043-1
sambasourcestretch2:4.5.12+dfsg-2+deb9u1highDSA-4043-1
sambasourcewheezy(not affected)

Notes

[wheezy] - samba <not-affected> (Issue introduced in 4.0.0)
https://www.samba.org/samba/security/CVE-2017-14746.html

Search for package or bug name: Reporting problems