CVE-2017-14849

NameCVE-2017-14849
DescriptionNode.js 8.5.0 before 8.6.0 allows remote attackers to access unintended files, because a change to ".." handling was incompatible with the pathname validation used by unspecified community modules.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nodejs (PTS)buster10.24.0~dfsg-1~deb10u1fixed
buster (security)10.24.0~dfsg-1~deb10u2fixed
bullseye12.22.5~dfsg-2~11u1fixed
bullseye (security)12.22.12~dfsg-1~deb11u1fixed
bookworm, sid18.12.1+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nodejssource(unstable)(not affected)

Notes

- nodejs <not-affected> (Vulnerable code introduced in 8.5.0)
https://nodejs.org/en/blog/vulnerability/september-2017-path-validation/
https://twitter.com/nodejs/status/913131152868876288

Search for package or bug name: Reporting problems