CVE-2017-14926

NameCVE-2017-14926
DescriptionIn Poppler 0.59.0, a NULL Pointer Dereference exists in AnnotRichMedia::Content::Content in Annot.cc via a crafted PDF document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2440-1
Debian Bugs877239

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)buster0.71.0-5fixed
buster (security)0.71.0-5+deb10u1fixed
bullseye20.09.0-3.1fixed
bullseye (security)20.09.0-3.1+deb11u1fixed
bookworm, sid22.08.0-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
popplersourcewheezy(not affected)
popplersourcejessie(not affected)
popplersourcestretch0.48.0-2+deb9u4DLA-2440-1
popplersource(unstable)0.61.1-2low877239

Notes

[jessie] - poppler <not-affected> (Problematic code introduced in 0.36)
[wheezy] - poppler <not-affected> (Problematic code introduced in 0.36)
https://bugs.freedesktop.org/show_bug.cgi?id=102601
https://cgit.freedesktop.org/poppler/poppler/commit/?id=2532df6060092e9fab7f041ae9598aff9cdd94bb

Search for package or bug name: Reporting problems