CVE-2017-14929

NameCVE-2017-14929
DescriptionIn Poppler 0.59.0, memory corruption occurs in a call to Object::dictLookup() in Object.h after a repeating series of Gfx::display, Gfx::go, Gfx::execOp, Gfx::opFill, Gfx::doPatternFill, Gfx::doTilingPatternFill and Gfx::drawForm calls (aka a Gfx.cc infinite loop), a different vulnerability than CVE-2017-14519.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs877222

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)jessie (security), jessie0.26.5-2+deb8u4vulnerable
stretch (security), stretch0.48.0-2+deb9u2fixed
buster, sid0.69.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
popplersource(unstable)0.61.1-2medium877222
popplersourcestretch0.48.0-2+deb9u2medium

Notes

[jessie] - poppler <ignored> (Minor impact, too intrusive to backport)
[wheezy] - poppler <ignored> (unreproducible, requires API change which appears to be too intrusive in this case.)
https://bugs.freedesktop.org/show_bug.cgi?id=102969
https://cgit.freedesktop.org/poppler/poppler/commit/?id=2c92c7b6a828c9db8a38f079ea7a3d51c12a481d

Search for package or bug name: Reporting problems