CVE-2017-14992

NameCVE-2017-14992
DescriptionLack of content verification in Docker-CE (Also known as Moby) versions 1.12.6-0, 1.10.3, 17.03.0, 17.03.1, 17.03.2, 17.06.0, 17.06.1, 17.06.2, 17.09.0, and earlier allows a remote attacker to cause a Denial of Service via a crafted image layer payload, aka gzip bombing.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs908055, 908056

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
docker.io (PTS)buster, sid18.06.1+dfsg1-2fixed
golang-github-vbatts-tar-split (PTS)stretch0.9.13-1vulnerable
buster, sid0.10.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
docker.iosource(unstable)18.03.1+dfsg1-2medium908055
golang-github-vbatts-tar-splitsource(unstable)0.10.2-1medium908056

Notes

[stretch] - golang-github-vbatts-tar-split <no-dsa> (Minor issue)
Issue needs to be fixed in src:golang-github-vbatts-tar-split first
https://github.com/vbatts/tar-split/issues/41
docker.io needs then a rebuild with a fixed golang-github-vbatts-tar-split
version.
17.12.1+dfsg-1 was the first upload (to experimental) using the fixed version
golang-github-vbatts-tar-split.

Search for package or bug name: Reporting problems