CVE-2017-15047

NameCVE-2017-15047
DescriptionThe clusterLoadConfig function in cluster.c in Redis 4.0.2 allows attackers to cause a denial of service (out-of-bounds array index and application crash) or possibly have unspecified other impact by leveraging "limited access to the machine."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs878076

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
redis (PTS)wheezy2:2.4.14-1fixed
wheezy (security)2:2.4.14-1+deb7u2fixed
jessie (security), jessie2:2.8.17-1+deb8u5fixed
stretch3:3.2.6-1vulnerable
buster, sid5:4.0.6-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
redissource(unstable)4:4.0.2-5unimportant878076
redissourcejessie(not affected)
redissourcewheezy(not affected)

Notes

[jessie] - redis <not-affected> (Vulnerable code introduced later)
[wheezy] - redis <not-affected> (Vulnerable code introduced later)
https://github.com/antirez/redis/issues/4278
Pull request: https://github.com/antirez/redis/pull/4365

Search for package or bug name: Reporting problems