CVE-2017-15091

NameCVE-2017-15091
DescriptionAn issue has been found in the API component of PowerDNS Authoritative 4.x up to and including 4.0.4 and 3.x up to and including 3.4.11, where some operations that have an impact on the state of the server are still allowed even though the API has been configured as read-only via the api-readonly keyword. This missing check allows an attacker with valid API credentials to flush the cache, trigger a zone transfer or send a NOTIFY.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pdns (PTS)jessie3.4.1-4+deb8u8fixed
jessie (security)3.4.1-4+deb8u7vulnerable
stretch4.0.3-1+deb9u2fixed
buster, sid4.1.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pdnssource(unstable)4.0.5-1medium
pdnssourcejessie3.4.1-4+deb8u8medium
pdnssourcestretch4.0.3-1+deb9u2medium
pdnssourcewheezy(not affected)

Notes

[wheezy] - pdns <not-affected> (Vulnerable code not present)
https://doc.powerdns.com/authoritative/security-advisories/powerdns-advisory-2017-04.html
https://downloads.powerdns.com/patches/2017-04/

Search for package or bug name: Reporting problems