CVE-2017-15093

NameCVE-2017-15093
DescriptionWhen api-config-dir is set to a non-empty value, which is not the case by default, the API in PowerDNS Recursor 4.x up to and including 4.0.6 and 3.x up to and including 3.7.4 allows an authorized user to update the Recursor's ACL by adding and removing netmasks, and to configure forward zones. It was discovered that the new netmask and IP addresses of forwarded zones were not sufficiently validated, allowing an authenticated user to inject new configuration directives into the Recursor's configuration.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pdns-recursor (PTS)jessie3.6.2-2+deb8u4fixed
jessie (security)3.6.2-2+deb8u3vulnerable
stretch (security), stretch4.0.4-1+deb9u3fixed
buster, sid4.1.4-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pdns-recursorsource(unstable)4.0.7-1low
pdns-recursorsourcejessie3.6.2-2+deb8u4low
pdns-recursorsourcestretch4.0.4-1+deb9u2low
pdns-recursorsourcewheezy(not affected)

Notes

[wheezy] - pdns-recursor <not-affected> (Vulnerable code introduced later)
https://doc.powerdns.com/recursor/security-advisories/powerdns-advisory-2017-06.html
https://downloads.powerdns.com/patches/2017-06/

Search for package or bug name: Reporting problems