CVE-2017-15118

NameCVE-2017-15118
DescriptionA stack-based buffer overflow vulnerability was found in NBD server implementation in qemu before 2.11 allowing a client to request an export name of size up to 4096 bytes, which in fact should be limited to 256 bytes, causing an out-of-bounds stack write in the qemu process. If NBD server requires TLS, the attacker cannot trigger the buffer overflow without first successfully negotiating TLS.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs883406

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie1:2.1+dfsg-12+deb8u6fixed
jessie (security)1:2.1+dfsg-12+deb8u8fixed
stretch1:2.8+dfsg-6+deb9u4fixed
stretch (security)1:2.8+dfsg-6+deb9u5fixed
buster1:2.12+dfsg-3fixed
sid1:3.1+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1:2.11+dfsg-1high883406
qemusourcejessie(not affected)
qemusourcestretch(not affected)
qemusourcewheezy(not affected)
qemu-kvmsource(unstable)(not affected)

Notes

[stretch] - qemu <not-affected> (Vulnerable code introduced in 2.10)
[jessie] - qemu <not-affected> (Vulnerable code introduced in 2.10)
[wheezy] - qemu <not-affected> (Vulnerable code introduced in 2.10)
- qemu-kvm <not-affected> (Vulnerable code introduced in 2.10)
Introduced by: https://git.qemu.org/?p=qemu.git;a=commit;h=f37708f6b8
https://lists.gnu.org/archive/html/qemu-devel/2017-11/msg05045.html

Search for package or bug name: Reporting problems