CVE-2017-15120

NameCVE-2017-15120
DescriptionAn issue has been found in the parsing of authoritative answers in PowerDNS Recursor before 4.0.8, leading to a NULL pointer dereference when parsing a specially crafted answer containing a CNAME of a different class than IN. An unauthenticated remote attacker could cause a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4063-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pdns-recursor (PTS)jessie3.6.2-2+deb8u4fixed
jessie (security)3.6.2-2+deb8u3fixed
stretch (security), stretch4.0.4-1+deb9u3fixed
buster, sid4.1.4-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pdns-recursorsource(unstable)4.1.0-1
pdns-recursorsourcejessie(not affected)
pdns-recursorsourcestretch4.0.4-1+deb9u3DSA-4063-1
pdns-recursorsourcewheezy(not affected)

Notes

[jessie] - pdns-recursor <not-affected> (Vulnerable code introduced in 4.0.0)
[wheezy] - pdns-recursor <not-affected> (Vulnerable code introduced in 4.0.0)
Patch: https://downloads.powerdns.com/patches/2017-08
https://doc.powerdns.com/recursor/security-advisories/powerdns-advisory-2017-08.html

Search for package or bug name: Reporting problems