CVE-2017-15124

NameCVE-2017-15124
DescriptionVNC server implementation in Quick Emulator (QEMU) 2.11.0 and older was found to be vulnerable to an unbounded memory allocation issue, as it did not throttle the framebuffer updates sent to its client. If the client did not consume these updates, VNC server allocates growing memory to hold onto this data. A malicious remote VNC client could use this flaw to cause DoS to the server host.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4213-1
NVD severityhigh (attack range: remote)
Debian Bugs884806

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie (security), jessie1:2.1+dfsg-12+deb8u6vulnerable
stretch1:2.8+dfsg-6+deb9u3vulnerable
stretch (security)1:2.8+dfsg-6+deb9u4fixed
buster, sid1:2.12+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1:2.12~rc3+dfsg-1high884806
qemusourcestretch1:2.8+dfsg-6+deb9u4highDSA-4213-1
qemu-kvmsource(unstable)(unfixed)high

Notes

[jessie] - qemu <postponed> (Can be fixed along in later update)
[wheezy] - qemu <postponed> (Can be fixed along in later update)
[wheezy] - qemu-kvm <postponed> (Can be fixed along in later update)
http://www.openwall.com/lists/oss-security/2017/12/19/4

Search for package or bug name: Reporting problems