CVE-2017-15134

NameCVE-2017-15134
DescriptionA stack buffer overflow flaw was found in the way 389-ds-base 1.3.6.x before 1.3.6.13, 1.3.7.x before 1.3.7.9, 1.4.x before 1.4.0.5 handled certain LDAP search filters. A remote, unauthenticated attacker could potentially use this flaw to make ns-slapd crash via a specially crafted LDAP request, thus resulting in denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1428-1
NVD severitymedium (attack range: remote)
Debian Bugs888452

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
389-ds-base (PTS)jessie1.3.3.5-4vulnerable
jessie (security)1.3.3.5-4+deb8u1fixed
stretch1.3.5.17-2vulnerable
sid1.3.8.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
389-ds-basesource(unstable)1.3.7.9-1medium888452
389-ds-basesourcejessie1.3.3.5-4+deb8u1mediumDLA-1428-1

Notes

Fixed by: https://pagure.io/389-ds-base/c/6aa2acdc3cad9

Search for package or bug name: Reporting problems