CVE-2017-15139

NameCVE-2017-15139
DescriptionA vulnerability was found in openstack-cinder releases up to and including Queens, allowing newly created volumes in certain storage volume configurations to contain previous data. It specifically affects ScaleIO volumes using thin volumes and zero padding. This could lead to leakage of sensitive information between tenants.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cinder (PTS)stretch2:9.0.0-4vulnerable
buster2:13.0.3-1fixed
bullseye2:17.0.1-1fixed
bookworm, sid2:20.0.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cindersourceexperimental2:13.0.0-1
cindersourcejessie(not affected)
cindersource(unstable)2:13.0.0-2

Notes

[stretch] - cinder <no-dsa> (Minor issue)
[jessie] - cinder <not-affected> (ScaleIO Driver support does not exist)
https://wiki.openstack.org/wiki/OSSN/OSSN-0084
https://bugs.launchpad.net/ossn/+bug/1699573

Search for package or bug name: Reporting problems