CVE-2017-15194

NameCVE-2017-15194
Descriptioninclude/global_session.php in Cacti 1.1.25 has XSS related to (1) the URI or (2) the refresh page.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs878304

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cacti (PTS)stretch (security), stretch0.8.8h+ds1-10+deb9u1fixed
buster1.2.2+ds1-2+deb10u4fixed
buster (security)1.2.2+ds1-2+deb10u2fixed
bullseye, sid1.2.16+ds1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cactisourcewheezy(not affected)
cactisourcejessie(not affected)
cactisourcestretch(not affected)
cactisource(unstable)1.1.25+ds1-1878304

Notes

[stretch] - cacti <not-affected> (Vulnerable code introduced in 1.0.0)
[jessie] - cacti <not-affected> (Vulnerable code introduced in 1.0.0)
[wheezy] - cacti <not-affected> (Vulnerable code introduced in 1.0.0)
https://github.com/Cacti/cacti/issues/1010
https://github.com/Cacti/cacti/commit/93f661d8adcfa6618b11522cdab30e97bada33fd
https://github.com/Cacti/cacti/commit/4f87256e63859117f81d2a2bd40c9c730e39b65d

Search for package or bug name: Reporting problems