CVE-2017-15268

NameCVE-2017-15268
DescriptionQemu through 2.10.0 allows remote attackers to cause a memory leak by triggering slow data-channel read operations, related to io/channel-websock.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)wheezy1.1.2+dfsg-6a+deb7u12fixed
wheezy (security)1.1.2+dfsg-6+deb7u24fixed
jessie (security), jessie1:2.1+dfsg-12+deb8u6fixed
stretch1:2.8+dfsg-6+deb9u2vulnerable
stretch (security)1:2.8+dfsg-6+deb9u3vulnerable
buster, sid1:2.10.0+dfsg-2vulnerable
qemu-kvm (PTS)wheezy1.1.2+dfsg-6+deb7u12fixed
wheezy (security)1.1.2+dfsg-6+deb7u24fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)(unfixed)
qemusourcejessie(not affected)
qemusourcewheezy(not affected)
qemu-kvmsource(unstable)(not affected)

Notes

[jessie] - qemu <not-affected> (I/O channels driver websockets introduced later)
[wheezy] - qemu <not-affected> (I/O channels driver websockets introduced later)
- qemu-kvm <not-affected> (I/O channels driver websockets introduced later)
https://lists.gnu.org/archive/html/qemu-devel/2017-10/msg02278.html
https://bugzilla.redhat.com/show_bug.cgi?id=1496879

Search for package or bug name: Reporting problems