CVE-2017-15275

NameCVE-2017-15275
DescriptionSamba before 4.7.3 might allow remote attackers to obtain sensitive information by leveraging failure of the server to clear allocated heap memory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1183-1, DSA-4043-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)jessie2:4.2.14+dfsg-0+deb8u9fixed
jessie (security)2:4.2.14+dfsg-0+deb8u13fixed
stretch (security), stretch2:4.5.16+dfsg-1+deb9u2fixed
buster2:4.9.5+dfsg-5fixed
buster (security)2:4.9.5+dfsg-5+deb10u1fixed
bullseye, sid2:4.11.1+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasource(unstable)2:4.7.1+dfsg-2
sambasourcejessie2:4.2.14+dfsg-0+deb8u9DSA-4043-1
sambasourcestretch2:4.5.12+dfsg-2+deb9u1DSA-4043-1
sambasourcewheezy2:3.6.6-6+deb7u15DLA-1183-1

Notes

https://www.samba.org/samba/security/CVE-2017-15275.html

Search for package or bug name: Reporting problems