CVE-2017-15281

NameCVE-2017-15281
DescriptionReadPSDImage in coders/psd.c in ImageMagick 7.0.7-6 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted file, related to "Conditional jump or move depends on uninitialised value(s)."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1139-1
NVD severitymedium (attack range: remote)
Debian Bugs878579

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)wheezy8:6.7.7.10-5+deb7u4vulnerable
wheezy (security)8:6.7.7.10-5+deb7u18fixed
jessie8:6.8.9.9-5+deb8u9vulnerable
jessie (security)8:6.8.9.9-5+deb8u10vulnerable
stretch (security), stretch8:6.9.7.4+dfsg-11+deb9u1vulnerable
buster, sid8:6.9.7.4+dfsg-16vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)(unfixed)low878579
imagemagicksourcewheezy8:6.7.7.10-5+deb7u18mediumDLA-1139-1

Notes

https://github.com/ImageMagick/ImageMagick/issues/832
ImageMagick-6: https://github.com/ImageMagick/ImageMagick/commit/e9d1c2adae866861a291535997b2263f26becb1e
https://github.com/ImageMagick/ImageMagick/commit/32cbfceeee57962321b2ead627129c9d9ffbfcdb

Search for package or bug name: Reporting problems