CVE-2017-15368

NameCVE-2017-15368
DescriptionThe wasm_dis function in libr/asm/arch/wasm/wasm.c in radare2 2.0.0 allows remote attackers to cause a denial of service (stack-based buffer over-read and application crash) or possibly have unspecified other impact via a crafted WASM file that triggers an incorrect r_hex_bin2str call.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs878767

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
radare2 (PTS)jessie0.9.6-3.1+deb8u1fixed
sid4.2.1+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
radare2source(unstable)2.1.0+dfsg-1878767
radare2sourcejessie(not affected)
radare2sourcewheezy(not affected)

Notes

[jessie] - radare2 <not-affected> (Vulnerable code introduced in 2.0.0)
[wheezy] - radare2 <not-affected> (Vulnerable code introduced in 2.0.0)
https://github.com/radare/radare2/issues/8673
https://github.com/radare/radare2/commit/52b1526443c1f433087928291d1c3d37a5600515

Search for package or bug name: Reporting problems