CVE-2017-15412

NameCVE-2017-15412
Descriptionuse after free
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1211-1, DSA-4086-1
Debian Bugs883790

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxml2 (PTS)wheezy2.8.0+dfsg1-7+wheezy5vulnerable
wheezy (security)2.8.0+dfsg1-7+wheezy12fixed
jessie2.9.1+dfsg1-5+deb8u5vulnerable
jessie (security)2.9.1+dfsg1-5+deb8u6fixed
stretch2.9.4+dfsg1-2.2+deb9u1vulnerable
stretch (security)2.9.4+dfsg1-2.2+deb9u2fixed
buster, sid2.9.4+dfsg1-6.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxml2source(unstable)2.9.4+dfsg1-5.2883790
libxml2sourcejessie2.9.1+dfsg1-5+deb8u6DSA-4086-1
libxml2sourcestretch2.9.4+dfsg1-2.2+deb9u2DSA-4086-1
libxml2sourcewheezy2.8.0+dfsg1-7+wheezy12DLA-1211-1

Notes

https://bugs.chromium.org/p/chromium/issues/detail?id=727039
https://bugzilla.gnome.org/show_bug.cgi?id=783160 (not public)
Fixed by: https://git.gnome.org/browse/libxml2/commit/?id=0f3b843b3534784ef57a4f9b874238aa1fda5a73

Search for package or bug name: Reporting problems