CVE-2017-15535

NameCVE-2017-15535
DescriptionMongoDB 3.4.x before 3.4.10, and 3.5.x-development, has a disabled-by-default configuration setting, networkMessageCompressors (aka wire protocol compression), which exposes a vulnerability when enabled that could be exploited by a malicious attacker to deny service or modify memory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mongodb (PTS)stretch1:3.2.11-2+deb9u1fixed
stretch (security)1:3.2.11-2+deb9u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mongodbsource(unstable)(not affected)

Notes

- mongodb <not-affected> (wire protocol compression introduced in 3.4.x and disabled by default)
https://jira.mongodb.org/browse/SERVER-31273

Search for package or bug name: Reporting problems