CVE-2017-15569

NameCVE-2017-15569
DescriptionIn Redmine before 3.2.8, 3.3.x before 3.3.5, and 3.4.x before 3.4.3, XSS exists in app/helpers/queries_helper.rb via a multi-value field with a crafted value that is mishandled during rendering of an issue list.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4191-1
NVD severitymedium (attack range: remote)
Debian Bugs882545

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
redmine (PTS)stretch (security), stretch3.3.1-4+deb9u2fixed
sid3.4.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
redminesource(unstable)3.4.4-1medium882545
redminesourcejessie(unfixed)end-of-life
redminesourcestretch3.3.1-4+deb9u1mediumDSA-4191-1
redminesourcewheezy(unfixed)end-of-life

Notes

[jessie] - redmine <end-of-life> (Not supported in Jessie-LTS)
[wheezy] - redmine <end-of-life> (Not supported in wheezy LTS)
https://www.redmine.org/projects/redmine/wiki/Security_Advisories
https://www.redmine.org/issues/27186 (private)
https://github.com/redmine/redmine/commit/56c8ee0440d8555aa7822d947ba9091c8a791508

Search for package or bug name: Reporting problems